Rancher
  • 1 minute to read
  • Print
  • Share
  • Dark
    Light

Rancher

  • Print
  • Share
  • Dark
    Light

Rancher is an open-source multi-cluster orchestration platform that enables operations teams to deploy, manage, and secure enterprise Kubernetes.

Types of Assets Fetched

This adapter fetches the following types of assets:

  • Devices

Parameters

  1. Host Name or IP Address (required) - The hostname or IP address of the Rancher server that Axonius can communicate with via the Required Ports.
  2. User Name and Password (required) - The credentials for a user account that has the Required Permissions to fetch assets.
  3. Verify SSL (required, default: False) - Verify the SSL certificate offered by the value supplied in Host Name or IP Address. For more details, see SSL Trust & CA Settings.
    • If enabled, the SSL certificate offered by the value supplied in Host Name or IP Address will be verified against the CA database inside of Axonius. If the SSL certificate can not be validated against the CA database inside of Axonius, the connection will fail with an error.
    • If disabled, the SSL certificate offered by the value supplied in Host Name or IP Address will not be verified against the CA database inside of Axonius.
  4. HTTPS Proxy (optional, default: empty) - A proxy to use when connecting to the value supplied in Host Name or IP Address.
    • If supplied, Axonius will utilize the proxy when connecting to the value supplied in Host Name or IP Address.
    • If not supplied, Axonius will connect directly to the value supplied in Host Name or IP Address.
  5. For details on the common adapter connection parameters and buttons, see Adding a New Adapter Connection.

image.png

Required Ports

  • HTTPS (443)

APIs

Axonius uses the Rancher API.

Required Permissions

The value supplied in User Name must have local admin credentials.

Version Matrix

This adapter has only been tested with the versions marked as supported, but may work with other versions. Please contact Axonius Support if you have a version that is not listed and it is not functioning as expected.

Version Supported Notes
Rancher API V3 Yes
Was this article helpful?